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C8051F00X/01X DEVELOPMENT KIT USER ’S GUIDE

1.  Kit Contents
The C8051F00x/01x Development Kit contains the following items:

• C8051F005 Target Board
• Serial Adapter (RS-232 to Target Board Protocol Converter)
• Silicon Laboratories IDE and Product Information CD-ROM.  CD content includes:

• Silicon Laboratories Integrated Development Environment (IDE)
• Keil Software 8051 Development Tools (macro assembler, linker, evaluation ‘C’ compiler)
• Installation utility (SETUP.EXE)
• Source code examples and register definition files
• Documentation

• AC to DC Power Adapter
• RS232 Serial Cable
• 7” Ribbon Cable
• Quick-start Guide
• C8051F00x/01x Development Kit User’s Guide (this document)

2.  Hardware Setup
The target board is connected to a PC running the Silicon Laboratories IDE via the Serial Adapter as shown in
Figure 1. 

1. Connect one end of the RS232 serial cable to a serial (COM) port on the PC.
2. Connect the other end of the RS232 serial cable to the DB-9 connector on the Serial Adapter.
3. Connect the Serial Adapter to the JTAG connector on the target board using the 10-pin ribbon cable.
4. Connect the AC/DC power adapter to power jack P1 on the target board.

Serial Port
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AC/DC
Adapter

Serial
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Figure 1. Hardware Setup

Note: The Reset switch on the target board is disabled when the serial adapter is connected to the
target board. Use the Reset button in the Silicon Laboratories IDE toolbar to reset the target when
connected to the Serial Adapter.
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3.  Software Setup
The included CD-ROM contains the Silicon Laboratories Integrated Development Environment (IDE), Keil software
8051 tools and additional documentation. Insert the CD-ROM into your PC’s CD-ROM drive. An installer will auto-
matically launch, allowing you to install the IDE software or read documentation by clicking buttons on the Installa-
tion Panel. If the installer does not automatically start when you insert the CD-ROM, run autorun.exe found in the
root directory of the CD-ROM. Refer to the readme.txt file on the CD-ROM for the latest information regarding
known IDE problems and restrictions.

4.  Silicon Laboratories Integrated Development Environment
The Silicon Laboratories IDE integrates a source-code editor, source-level debugger and in-system Flash program-
mer. The use of third-party compilers and assemblers is also supported. This development kit includes the Keil
Software A51 macro assembler, BL51 linker and evaluation version C51 ‘C’ compiler. These tools can be used
from within the Silicon Laboratories IDE.

4.1.  System Requirements
The Silicon Laboratories IDE requirements:

• Pentium-class host PC running Microsoft Windows 95 or later, or Microsoft Windows NT or later.
• One available COM port.
• 64 MB RAM and 40 MB free HD space recommended.

4.2.  Assembler and Linker
A full-version Keil A51 macro assembler and BL51 banking linker are included with the development kit and are
installed during IDE installation. The complete assembler and linker reference manual can be found on-line under
the Help menu in the IDE or in the “SiLabs\MCU\hlp” directory (A51.pdf).

4.3.  Evaluation C51 ‘C’ Compiler
An evaluation version of the Keil C51 ‘C’ compiler is included with the development kit and is installed during IDE
installation. The evaluation version of the C51 compiler is the same as the full professional version except code
size is limited to 4 kB and the floating point library is not included. The C51 compiler reference manual can be
found under the Help menu in the IDE or in the “SiLabs\MCU\hlp” directory (C51.pdf).

4.4.  Using the Keil Software 8051 Tools with the Silicon Laboratories IDE
To perform source-level debugging with the IDE, you must configure the Keil 8051 tools to generate an absolute
object file in the OMF-51 format with object extensions and debug records enabled. You may build the OMF-51
absolute object file by calling the Keil 8051 tools at the command line (e.g. batch file or make file) or by using the
project manager built into the IDE. The default configuration when using the Silicon Laboratories IDE project
manager enables object extension and debug record generation. Refer to Applications Note AN104 - Integrating
Keil 8051 Tools Into the Silicon Labs IDE in the “SiLabs\MCU\Documentation\Appnotes” directory on the CD-
ROM for additional information on using the Keil 8051 tools with the Silicon Laboratories IDE. 

To build an absolute object file using the Silicon Laboratories IDE project manager, you must first create a project. A
project consists of a set of files, IDE configuration, debug views, and a target build configuration (list of files and tool
configurations used as input to the assembler, compiler, and linker when building an output object file).

The following sections illustrate the steps necessary to manually create a project with one or more source files, build
a program and download the program to the target in preparation for debugging. (The IDE will automatically create a
single-file project using the currently open and active source file if you select Build/Make Project before a project is
defined.) 
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4.4.1. Creating a New Project
1. Select Project->New Project to open a new project and reset all configuration settings to default.

2. Select File->New File to open an editor window. Create your source file(s) and save the file(s) with a rec-
ognized extension, such as .c, .h, or .asm, to enable color syntax highlighting.

3. Right-click on “New Project” in the Project Window. Select Add files to project. Select files in the file
browser and click Open. Continue adding files until all project files have been added.

4. For each of the files in the Project Window that you want assembled, compiled and linked into the target
build, right-click on the file name and select Add file to build. Each file will be assembled or compiled as
appropriate (based on file extension) and linked into the build of the absolute object file.

Note: If a project contains a large number of files, the “Group” feature of the IDE can be used to organize. 
Right-click on “New Project” in the Project Window. Select Add Groups to project. Add pre-defined 
groups or add customized groups. Right-click on the group name and choose Add file to group. Select files 
to be added. Continue adding files until all project files have been added.

4.4.2. Building and Downloading the Program for Debugging
1. Once all source files have been added to the target build, build the project by clicking on the Build/Make

Project button in the toolbar or selecting Project->Build/Make Project from the menu.

Note: After the project has been built the first time, the Build/Make Project command will only build the 
files that have been changed since the previous build. To rebuild all files and project dependencies, click 
on the Rebuild All button in the toolbar or select Project->Rebuild All from the menu.

2. The C8051F00x/01x device family uses the JTAG debug interface. You must select JTAG in the
Options->Debug Interface menu to enable connection to C8051F00x/01x target devices. Click the Connect
button in the toolbar or select Debug->Connect from the menu to connect to the device. 

3. Download the project to the target by clicking the Download Code button in the toolbar.

Note: To enable automatic downloading if the program build is successful select Enable automatic con-
nect/download after build in the Project->Target Build Configuration dialog. If errors occur during the 
build process, the IDE will not attempt the download.

4. Save the project when finished with the debug session to preserve the current target build configuration,
editor settings and the location of all open debug views. To save the project, select Project->
Save Project As... from the menu. Create a new name for the project and click on Save.
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5.  Example Source Code
Example source code and register definition files are provided in the “SiLabs\MCU\Examples\C8051F0xx” directory
during IDE installation. These files may be used as a template for code development. Example applications include
a blinking LED example which configures the green LED on the target board to blink at a fixed rate.

5.1.  Register Definition Files
Register definition files C8051F000.inc and C8051F000.h define all SFR registers and bit-addressable
control/status bits for the C8051F00x/01x device family. They are installed into the
“SiLabs\MCU\Examples\C8051F0xx” directory during IDE installation. The register and bit names are identical to
those used in the C8051F00x/01x data sheet. Both register definition files are also installed in the default search
path used by the Keil Software 8051 tools. Therefore, when using the Keil 8051 tools included with the
development kit (A51, C51), it is not necessary to copy a register definition file to each project’s file directory. 

5.2.  Blinking LED Example
The example source files blink.asm and blinky.c show examples of several basic C8051F00x/01x functions. These
include; disabling the watchdog timer (WDT), configuring the Port I/O crossbar, configuring a timer for an interrupt
routine, initializing the system clock, and configuring a GPIO port. When compiled/assembled and linked this pro-
gram flashes the green LED on the target board about five times a second using the interrupt handler with a timer. 
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6.  Target Board
The C8051F00x/01x Development Kit includes a target board with a C8051F005 device pre-installed for evaluation
and preliminary software development. Numerous input/output (I/O) connections are provided to facilitate prototyp-
ing using the target board. Refer to Figure 2 for the locations of the various I/O connectors.

P1 Power connector (accepts input from 7 to 15 VDC unregulated power adapter)
J1 Connects SW2 to port pin P1.7
J2 64-pin I/O connector providing access to all I/O signals
J3 Connects LED D3 to port pin P1.6
J6 Analog I/O configuration connector
X1 Analog I/O terminal block
JTAG Connects the Serial Adapter to the target board via a 10-pin ribbon cable

Figure 2. C8051F005 Target Board
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6.1.  System Clock Sources
The C8051F005 device installed on the target board features a internal oscillator which is enabled as the system
clock source on reset. After reset, the internal oscillator operates at a frequency of 2MHz (+/-2%) by default but
may be configured by software to operate at other frequencies. Therefore, in many applications an external oscilla-
tor is not required. However, an external crystal may be installed on the target board for additional applications. The
target board is designed to facilitate the installation of an external crystal at the pads marked Q1. Refer to the
C8051F005 datasheet for more information on configuring the system clock source. Following are a few part num-
bers of suitable crystals:

Freq(MHz) Digikey P/N ECS P/N 
18.432 X146-ND ECS-184-20-1 (20 pF loading capacitance)
11.0592 X089-ND ECS-110.5-20-1 (20 pF loading capacitance)

6.2.  Switches and LEDs
Two switches are provided on the target board. Switch SW1 is connected to the RESET pin of the C8051F005
device on the target board. Pressing SW1 puts the device into its hardware-reset state. The device will leave the
reset state after SW1 is released. Switch SW2 is connected to the device’s general purpose I/O (GPIO) pin through
jumpers. Pressing SW2 generates a logic low signal on the port pin. Remove the shorting block from the jumper to
disconnect SW2 from the port pins. The port pin signal is also routed to a pin on the J2 I/O connector. See Table 1
for the port pins and jumpers corresponding to each switch.

Two LEDs are also provided on the target board. The red LED labeled PWR is used to indicate a power connection
to the target board. The green LED labeled with a port pin name is connected to the device’s GPIO pin through
jumpers. Remove the shorting block from the jumper to disconnect the LED from the port pin. The port pin signal is
also routed to a pin on the J2 I/O connector. See Table 1 for the port pins and jumpers corresponding to each LED.

6.3.  Target Board JTAG Interface (J4)
The JTAG connector (J4) provides access to the JTAG pins of the C8051F005 device on the target board. It is used
to connect the Serial Adapter to the target board for in-circuit debugging and Flash programming. Table 2 shows
the JTAG pin definitions. 

Table 1.  Target Board I/O Descriptions
Description I/O Jumper

SW1 Reset none
SW2 P3.7 J1

Green LED P1.6 J3
Red LED PWR none

Table 2.  JTAG Connector Pin Descriptions
Pin # Description

1 +3VD (+3.3VDC)
2, 3, 9 GND (Ground)

4 TCK
5 TMS
6 TDO
7 TDI

8, 10 Not Connected
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6.4.  Analog I/O (J6, Terminal Block)
An Analog I/O Configuration Jumper (J6) provides the ability to route analog I/O signals from the C8051F005
device to a terminal block by installing two shorting blocks on J6.  It also allows the DAC outputs to be connected to
Comparator 0 inputs or to two ADC inputs. Analog signals may be routed to the AIO 0 and AI01 posts of the termi-
nal block by installing a shorting jumper between two adjacent pins on J6. Refer to Figure 3 to determine the short-
ing block installation positions required to connect the desired analog signal to the terminal block. Refer to Table 3
for terminal block connections and Table 4 for J6 pin definitions.    

Table 3.  Terminal Block Pin Descriptions
Pin # Description

1 AIO1
2 AIO0
7 AGND (Analog Ground)
8 VREF

Table 4.  J6 Jumper Block Pin Descriptions
Pin # Description

1 CP0+
2 CP0-

3, 9, 15 AIO1
4, 10, 16 AIO0

5 DAC0
6 DAC1
7 AIN0
8 AIN1
11 AIN2
12 AIN3
13 AIN4
14 AIN5
17 AIN6
18 AIN7
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Figure 3. J6 Analog I/O Configuration Connector
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6.5.  Expansion I/O Connector (J2)
The 64-pin expansion I/O connector J1 provides access to most signal pins of the C8051F005 device on the target
board. A small through-hole prototyping area is also provided. All I/O signals routed to connector J2 are also routed to
through-hole connection points between J2 and the prototyping area (see Figure 5 on page 10). The signal layout
pattern of these connection points is identical to the adjacent J2 connector pins. See Table 5  for a list of pin descrip-
tions for J2.

Table 5: J2 Pin Descriptions

Pin Description Pin Description

1 +VD (digital voltage supply) 28 P3.7

2 XTAL1 29 P3.4

3 P1.6 30 P3.5

4 P1.7 31 P3.2

5 P1.4 32 P3.3

6 P1.5 33 P3.0

7 P1.2 34 P3.1

8 P1.3 36 /RST

9 P1.0 39,41,42 GND (digital ground)

10 P1.1 45,47,63 GNDA (analog ground)

11 P0.6 46,64 +VA (analog voltage supply)

12 P0.7 48 DAC0

13 P0.4 49 CP1-

14 P0.5 50 DAC1

15 P0.2 51 CP1+

16 P0.3 52 CP0-

17 P0.0 53 VREF

18 P0.1 54 CP0+

19 P2.6 55 AIN0

20 P2.7 56 AIN1

21 P2.4 57 AIN2

22 P2.5 58 AIN3

23 P2.2 59 AIN4

24 P2.3 60 AIN5

25 P2.0 61 AIN6

26 P2.1 62 AIN7

27 P3.6
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7.  Serial Adapter
The Serial Adapter provides the interface between the PC’s RS232 serial port and the target device’s in-system
debug/programming circuitry. The Serial Adapter connects to the C8051F005 JTAG debug interface on the target
board using the 10-pin connector on the Serial Adapter labeled “JTAG”, see Figure 4. (The Serial Adapter supports
both Silicon Laboratories JTAG and C2 debug interfaces.). All Serial Adapters may be powered from the target
board, but the EC1 and EC2 Serial Adapter units cannot provide power to the target board. Table 6 shows the pin
definitions for the Serial Adapter’s JTAG connector.

Notes:
1. When powering the Serial Adapter via the JTAG connector, the input voltage to the JTAG connector’s

power pin must be 3.0 to 3.6 VDC. Otherwise, the Serial Adapter must be powered directly by connecting
the AC/DC adapter to the Serial Adapter’s DC power jack.

2. The Serial Adapter requires a target system clock of 32Khz or greater. 

Table 6.  JTAG/DEBUG Connector Pin Descriptions
Pin # Description

1 3.0 to 3.6VDC Input
2 GND (Ground)
4 TCK (C2DAT)
5 TMS
6 TDO
7 TDI (C2CLK)

3,8,9,10 Not Connected
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Figure 4. Serial Adapter JTAG Connector
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8.  Schematic
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DOCUMENT CHANGE LIST

Revision 0.3 to Revision 0.4
Integrated the Note! on the front page into the “6. 
Target Board”  section.
moved “2. Hardware Setup”  to front page.
Created section 5 from the "Example Source code" 
section 4.5.
Added Section 5.2, "Blinking LED Example".
Reorganized “6. Target Board”  section.
Added Section “6.3. Target Board JTAG Interface 
(J4)” .
Added Table 3, “Terminal Block Pin Descriptions,” on 
page 7.
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CONTACT INFORMATION
Silicon Laboratories Inc.
4635 Boston Lane
Austin, TX 78735
Tel: 1+(512) 416-8500
Fax: 1+(512) 416-9669
Toll Free: 1+(877) 444-3032
Email: productinfo@silabs.com
Internet: www.silabs.com

Silicon Laboratories and Silicon Labs are trademarks of Silicon Laboratories Inc.
Other products or brandnames mentioned herein are trademarks or registered trademarks of their respective holders.

The information in this document is believed to be accurate in all respects at the time of publication but is subject to change without notice. 
Silicon Laboratories assumes no responsibility for errors and omissions, and disclaims responsibility for any consequences resulting from 
the use of information included herein. Additionally, Silicon Laboratories assumes no responsibility for the functioning of undescribed features 
or parameters. Silicon Laboratories reserves the right to make changes without further notice. Silicon Laboratories makes no warranty, rep-
resentation or guarantee regarding the suitability of its products for any particular purpose, nor does Silicon Laboratories assume any liability 
arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation conse-
quential or incidental damages. Silicon Laboratories products are not designed, intended, or authorized for use in applications intended to 
support or sustain life, or for any other application in which the failure of the Silicon Laboratories product could create a situation where per-
sonal injury or death may occur. Should Buyer purchase or use Silicon Laboratories products for any such unintended or unauthorized ap-
plication, Buyer shall indemnify and hold Silicon Laboratories harmless against all claims and damages. 
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