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Document Conventions

The following table describes each typographic convention used in this
manual.

Example of Convention Description

Setup Entries to be typed by the user appear
in bold.  For example, “Type setup at
the prompt.”

Insert menu Button, icon, menu, and command
names appear in bold title caps.

Variable Italic letters indicate placeholders for
information the user supplies.  Italic
formatting is also used for book titles,
figure headings, and occasionally for
emphasis.

Set task_priority = 10

Set task_stack_size =
40000

This font is used for code.

CY.EXE Words in all capital letters indicate
filenames.  All capital letters are also
used for directory and folder names.

ENTER Small capital letters are used for the
names of keys and key sequences,
such as ENTER and CTRL+R.

ALT+F1 A plus sign (+) between key names
indicates a combination of keys.  For
example, ALT+F1 means to hold down
the ALT key while pressing the F1 key.
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Example of Convention Description

ALT,F,S,ENTER A comma (,) between key names
indicates that the individual keys are
pressed in sequence.

DOWN ARROW Individual direction keys are referred
to by the direction of the arrow on the
key top (LEFT, RIGHT, UP, or DOWN).
The phrase “arrow keys” is used when
describing these keys collectively.

BACKSPACE, HOME Other navigational keys are referred to
by their specific names.

Universal Serial Bus
(USB)

Acronyms are spelled out the first
time they are used.  For a complete
list of acronyms used in this manual,
refer to Appendix A, “Acronyms and
Abbreviations”.

Manual Organization

This manual is composed of three chapters:

Chapter 1 is the INTRODUCTION.  This chapter covers the basic
capabilities of the system, the system requirements, where to look for
help, who to call for technical support, and an overview of the CYDB
Main Window.

Chapter 2 is FUNCTIONS.  This chapter describes each element
(dialog box, menu item, etc.) of the development kit software.

Chapter 3 contains the APPENDICES.  This chapter contains the list
of acronyms and abbreviations and the detailed hardware description.
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1.1 Overview

The CYDB Debugger/CY3654 Development Kit is an easy-to-use kit
for application code development.  It is a combination of hardware and
software designed to allow firmware developers to design, debug, test,
and emulate the firmware of microcontrollers for a variety of target
applications.

This document is intended to be used as a reference to the elements of
the CYDB software.  It is not intended to be a step-by-step guide
through the use of the kit.  For step-by-step instructions, refer to the
CYDB User’s Guide.  For information regarding the hardware in the
CY3654 Development Kit, see Appendix B, “Detailed Hardware
Description.”

1.2 System Requirements

To install and run the CYDB Debugger/CY3654 Development Kit,
your computer must have at least the basic Windows 95/NT setup.
Minimum requirements include:

• Windows 95 or later operating system or Windows NT
Workstation operating system version 4.0 or later.

• An Intel Pentium or higher CPU.

• At least 16 megabytes (MB) of Random Access Memory
(RAM).

• A personal computer (PC) hard disk or shared network drive
with at least 20 MB of hard memory available.

• A video graphics adapter (VGA) monitor.
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• A CD-ROM drive.

• A serial input/output (I/O) port.

• A mouse or other suitable pointing device. (The software can
be operated without a mouse.  However, using a mouse
facilitates use of the software.)

1.3 Help Sources

The following help sources are available:

• CYDB User’s Guide.

• CYDB Reference Manual.

• Online help.

1.4 Technical Support

For technical support:

Web Site: http://www.cypress.com

E-mail: CYAPPS@cypress.com
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1.5 CYDB Main Window

The CYDB Main Window is the foundation of the user interface.  It is
from here that you:

• Download, run, and debug applications;

• Run the emulator;

• Configure the target chip, emulator, and platform board;

• and view the Data Memory, Program Memory, CPU Registers,
I/O Registers, Memory FIFO, Breakpoints, and .LST File
windows.

The CYDB Main Window also allows you to configure your
workspace and customize the toolbars and command buttons.

Figure 1 – The CYDB Main Window
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2.1 Overview

This chapter describes the function of each element of the CYDB
software.  It is separated into six sections: Overview, Buttons, Status
Bar Items, Menu Items, Dialog Boxes, and Windows.

2.1.1 How the Software Works with the Hardware

Although this Reference Manual focuses on the elements of the CYDB
software, it is important to note the relationship between the hardware
and the software.  The CYDB software is your connection between the
“host” system where CYDB is run, and the emulator system where
your programs run. The emulator has the ability to configure the
emulator for multiple microcontrollers.

The emulator governs the communication between your host and
target, so you can debug without consuming target resources.  It can
reproduce the behavior of real or theoretical target hardware on your
host platform.  Then, you can debug software before hardware is
available or while target hardware is not connected to your host.  You
can emulate any device: mouse, keyboard, joystick, scanner, printer,
camera, zip drive, etc.
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2.2 Buttons

The following table describes each command button and box in the
CYDB Main Window and dialog boxes.

Button Name Action

About Displays the About Dialog Box.

Browse Activates the Open Dialog Box for browsing
for files.

Close Closes the current window or dialog box.

Download Displays the Download dialog box for
downloading programs.

Maximize Increases the size of the window to maximum.

Minimize Hides the current window.

Open Activates the Open dialog box.

Reset Resets the microcontroller.

Reduce Reduces the size of the current window to
allow reshaping and moving.

Run Runs the selected program.

Step Runs the program until the next instruction.  If
the program counter starts on a function call,
“step” calls the function, then stops at the first
instruction within the function.

Stop Stops the program while it is running.  The
program counter positions itself on the next
instruction that will be executed when you
restart the program.
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2.3 Status Bar Items

The following table describes each status indicator on the status bar in
the CYDB Main Window.

Item Indicator Description

* A Register Indicates the value of the
Accumulator.

* Carry Flag Shows the status of the
Carry/Borrow Flag.

Caps Lock Indicates that the Caps Lock is on.

Connection Indicates whether or not the
connection to the development
board is established.

* DSP
Register

Indicates the value of the Data
Stock Pointer.

Number
Lock

Indicates that the Number Lock is
on.

* PC
Register

Indicates the value of the Program
Counter.

* PSP
Register

Indicates the value of the Program
Stock Pointer.

Scroll Lock Indicates that the Scroll Lock is on.

Status Indicates the status of the
development board.

* X Register Indicates the value of the Index
Register.

* Zero Flag Shows the status of the Zero Flag

* Refer to the Cypress USB Development Kit Assembler Guide.
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2.4 Menu Items

The following table describes each menu and sub-menu item in the
CYDB Main Window.  The items in the table appear in the same order
in which they appear in the CYDB Main Window.

Menu/Sub-menu Item Shortcut Description

ALT+F Displays the File menu.

CTRL+O
or
ALT+F,O

Displays the Open dialog box.

Closes the selected window.

Displays the Open Workspace dialog
box.

Saves the current workspace settings in
the current workspace file.

Displays the Save Workspace dialog box.

Closes the workspace, including any
open windows.

ALT+F,F Displays the Recent Files sub-menu:

Click the file you want to open.
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Menu/Sub-menu Item Shortcut Description

ALT+F,W Displays the Recent Workspaces sub-
menu:

Click the workspace you want to open.
Remember, DEFAULT.WSP is the
default workspace.

ALT+F4
or
ALT+F,X

Closes the CYDB Main Window.

ALT+E Displays the Edit menu.

Displays the Breakpoints window.

Moves the cursor to the PC register location
(i.e., 0000) in the listing window.

ALT+V Displays the View menu.

Toggles the status bar on and off.

Displays the Data Memory window.

Displays the Program Memory window.

Displays the CPU Registers window.
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Menu/Sub-menu Item Shortcut Description

Displays the IO Registers window.

Displays the Memory FIFO window.

Displays the Breakpoints window.

Refreshes the current window(s).

Reloads the .LST file.

ALT+R Displays the Run menu.

Starts the program from the program
counter position.

Stops the program.  While the program is
running, you can stop it at any time.  The
program counter positions itself on the
next instruction that will be executed
when you start the program again.

Steps through a program.  A step
corresponds to one instruction.

Resets the micontroller, resets all
variables and registers, and resets the
target hardware if it is connected.
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Menu/Sub-menu Item Shortcut Description

Displays the Connect to Target dialog
box 1.

Displays the Download dialog box.

NOTE: Before you begin downloading
and running an application, make sure the
platform board is properly connected to
the development PC and the target USB
controller (refer to section 1.3,
“Installation” of the CYDB User’s
Guide).

Resets the connection to the emulator.

ALT+C Displays the Configure menu.

Displays the Workspace sub-menu.

Displays the Customize dialog box with
the Toolbars tab selected.

Displays the Workspace Options dialog
box.

Displays the Configure Target/Emulator
dialog box.

Displays the Configure Development
Board Emulator dialog box.
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Menu/Sub-menu Item Shortcut Description

ALT+W Displays the Window menu.

Opens a new window.

Arranges the open windows in an
overlapping manner in the CYDB Main
Window.

Arranges the open windows in the CYDB
Main Window so that each window is
visible.

Arranges the minimized windows left to
right across the bottom of the CYDB
Main Window.

Items listed after the Arrange Icons menu
item are open files.  The  indicates the
current file.

Alt+H Displays the Help menu.

Displays the online help.

Displays the About dialog box.
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2.5 Dialog Boxes

This section describes each dialog box available from the CYDB Main
Window.  This section shows the dialog boxes in alphabetical order.

2.5.1 About

The About dialog box shows the platform board and firmware revision
installed, the platform configuration and version, the personality board
revision, and the CYDB Debugger software version.

• From the Help menu, click About CYDB, or click the About
( ) button.   The About dialog box appears:

Figure 2 – About Dialog Box

Click OK to close the About dialog box.
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2.5.2 Configure Development Board Emulator Dialog
Box

To update the firmware on the platform board, perform the following:

• From the Configure menu, click Update Firmware.  The
Configure Development Board Emulator dialog box appears:

Figure 3 – Configure Development Board Emulator Dialog Box

Select the desired emulator.

Click OK to update the firmware.

Click Cancel to exit without selecting an
emulator configuration.
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2.5.3 Configure Target/Emulator Dialog Box

To reconfigure the platform board to emulate a different
microcontroller, perform the following:

• From the Configure menu, click Target.  The Development
Board sub-menu appears.

• Click Platform.  The Configure Target/Emulator dialog box
appears:

Figure 4 – Configure Target/Emulator Dialog Box
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Type or select the microcontroller you want to
emulate.  The text boxes show the specified
information for the selected microcontroller.

Displays the configuration for the default
chip.

Displays the configuration for the chip
currently selected in the workspace.

Connects to the Development Board.

Updates the platform board to emulate the
selected chip.

Click OK to confirm the microcontroller
selection.

Click Cancel to exit without changing the
selection.
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2.5.4 Configuring Development Board Message

• At the Configure Target/Emulator dialog box, click Update to
update the chip configuration.

Ø If the Development Board is not ready, the Development
Board Not Ready dialog box appears (see Figure 12).

Ø Follow the Instructions and click OK.  The Configuring
Development Board Message appears:

Figure 5 – Configuring Development Board Message

Ø Wait for the download to complete.
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2.5.5 Connect to Target Dialog Box 1

• In the CYDB Main Window, click Run on the menu bar.  The
Run menu appears.

• Click Connect. The Connect to Target dialog box 1 appears:

Figure 6 – Connect to Target Dialog Box 1

Select the communications port you want to
connect to.

Click OK to connect to the port.  The Connect
to Target dialog box 2 appears (see Figure 6).

To exit without connecting, click Cancel.
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2.5.6 Connect to Target Dialog Box 2

Figure 7 – Connect to Target Dialog Box 2

• Click Abort if you want to abort the connection
process.  The dialog box disappears when the
connection is complete or if the connection times out
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2.5.7 Customize Dialog Box - Toolbars

This section describes the check boxes and buttons available in the
Customize dialog box when the Toolbars tab is selected.

• From the Workspace sub-menu, click Customize.  The
Customize dialog box appears with the Toolbars tab selected:

Figure 8 – Customize Dialog Box – Toolbars
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Click the Commands tab to view the
Commands tabbed page (see “Customize
Dialog Box – Commands”).

Click the Toolbars tab to display the Toolbars
tabbed page.

The Menu bar check box is always selected.
You can not clear this selection.

Select the File check box to enable the File
toolbar.

For a description of each button, see Section
2.2, “Buttons.”

Select the Debug check box to enable the
Debug toolbar.

For a description of each button, see Section
2.2, “Buttons.”

Select the Default check box to enable the
Default toolbar.

For a description of each button, see Section
2.2, “Buttons.”
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Select the Show Tooltips check box if you
want to display ToolTips when the mouse
pointer is over a button:

Select the Cool Look check box if you want to
change the appearance of the menu bar and
tool bar(s):

Leave the Cool Look check box blank if you
want to leave the menu bar and toolbars as
they are:

Select the Large Buttons check box if you
want to make the command buttons appear
larger:

In the Toolbars group box, click on the name
of the new toolbar you want to delete and
click Delete.  The new toolbar name is
removed from the Toolbars group box and the
new toolbar is removed from the CYDB Main
Window.

NOTE:  The Delete button does not appear
unless there is at least one new toolbar.
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In the Toolbars group box, click New.  The
New Toolbar dialog box appears (see “New
Toolbar”).

If you add a number of menu bar or toolbar
items, you can reset the changes before you
click OK.  Click Reset to return the toolbars
and menu bar to their previous configuration.

Once you have made all the changes to the
workspace, click OK.

NOTE:  Clicking Cancel will only undo the
changes made to the Show Tooltips, Cool
Look, and Large Buttons check boxes before
closing the Customize dialog box.

Click Help to display the online help.
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New Toolbar

Figure 9 – New Toolbar Dialog Box

Type the name you want to give your new
toolbar.

Click OK.  The new toolbar name appears in
the Toolbars group box and the new toolbar
appears in the CYDB Main Window.

Click Cancel to return to the Customize dialog
box without setting a new toolbar name.

Click Help to display the online help.
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Customize Dialog Box - Commands

This section describes the check boxes and buttons available in the
Customize dialog box when the Commands tab is selected.

• From the Workspace sub-menu, click Customize.  The
Customize dialog box appears with the Toolbars tab selected.

• Click the Commands tab to view the Commands tabbed page:

Figure 10 – Customize Dialog Box –Commands
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Menu is currently the only selection available.
For descriptions of the available menu items,
see Section 2.4, “Menu Items.”

• Click a menu name and drag it to the
menu bar.

• To remove a menu name from the menu
bar, drag it back to the Customize
dialog box.

Once you have made all the changes to the
workspace, click OK.

Click Cancel to exit the Customize dialog box
without saving your changes.

NOTE:  Clicking Cancel will only undo the
changes made to the Show Tooltips, Cool
Look, and Large Buttons check boxes on the
Toolbars tab before closing the Customize
dialog box.

Click Help to display the online help.
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2.5.8 CYDB Not Connected

If you try to access the development board from the Configure
Development Board Emulator dialog box or the Configure
Target/Emulator dialog box and the development board is not ready
for configuration, the following Error message appears:

Figure 11 – Error Message

Click OK to acknowledge the error.
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2.5.9 Development Board Not Ready

Figure 12 – Development Board Not Ready Dialog Box

Follow the instructions in the dialog box and
then click OK.

Click Cancel to return to the CYDB Main
Window.

This ensures that the emulator is in boot mode for reconfiguring the
platform board or updating the firmware.
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2.5.9 Download File to Emulator

From the Run menu, click Download, or click the Download ( )
button.  The Download dialog box appears:

Figure 13 – Download Dialog Box

In the first box, enter the path and filename of
the application you want to download, or you
can browse for it (see “Select File”).

In the second box, enter the path and filename
of the associated listing file, or you can
browse for it (see “Open File”).

Click OK to download the program to the
emulator, and to update and open the .LST
file.

Click Cancel to exit without downloading.
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Select File

• At the Download dialog box, click the browse ( ) button.
The Select File dialog box appears:

Figure 14 – Select File Dialog Box

Select the application you want to download.

Click Open.  The Download dialog box
reappears with the application’s path and
filename entered in the text box.

NOTE:  Applications have the .ROM or .HEX
file extension.  Listing files have the .LST file
extension.
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Open File

The Open dialog box is used to open .LST files for setting breakpoints
or for selecting files for you workspace configuration.

• From the File menu, click Open.  The Open dialog box
appears:

Figure 15 – Open Dialog Box

Select the file you want to download.

Click Open to open the file.

Click Cancel to exit without selecting a file.
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2.5.10 Open Workspace

The Open Workspace dialog box allows you to open your customized
workspace.

• From the File menu, click Open Workspace.  The open
Workspace dialog box appears:

Figure 16 – Open Workspace Dialog box

Select the workspace you want to open.

Click Open.  The attributes of the saved
workspace are applied to the CYDB Main
Window.

Click Cancel to exit the Open Workspace
dialog box without selecting a workspace.
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2.5.11 Save Workspace

The Save Workspace dialog box allows you to save your customized
workspace as a .WSP file.

• From the File menu, click Save Workspace As.  The Save
Workspace dialog box appears:

Figure 17 – Save Workspace Dialog Box

Select a .WSP file or type the name you want
to give the workspace.

NOTE: DEFAULT.WSP is the default
workspace file.  Do not select this filename
unless you want to make the current
workspace your default workspace.
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Click Save to save the workspace.

Click Cancel to close the Save Workspace
dialog box without saving the file.
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2.5.12 Workspace Options

The Workspace Options dialog box allows you two options:  Connect
on start and Load Last Workspace.

• From the Workspace sub-menu, click Options.  The
Workspace Options dialog box appears:

Figure 18 – Workspace Options Dialog Box

Select Connect on start to automatically
connect to the development board upon
opening the CYDB Main Window.

Select Load Last Workspace to
automatically open the workspace you last
used before closing the CYDB Main Window.

Click OK to apply the options.

Click Cancel to exit the Workspace Options
dialog box without selecting an option.
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2.6 Windows

This section describes the seven windows used in the CYDB Main
Window.   Each window is accessed via the View menu except the
.LST File Window.

2.6.1 Data Memory Window

The Data Memory window displays the contents of the RAM.

• From the View menu, select Memory.  The Data Memory
window appears.

Figure 19 – Data Memory Window
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You can not modify data in the address field.
Each address represents a different group of
programming lines.

Each value field (0 – f) represents a different
line of programming. For example, the cell in
row 0x000090 and column 2 contains the
program code for line 0x000092.

You can only modify data in the Value fields.  You can not modify
data in the Address field.  To make a change to the RAM program:

• Double click the cell you want to change.

• Type the new value in that field.

Ø  Press [Enter] to save the change.

Ø Press [Esc] to cancel the change.
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2.6.2 Program Memory Window

The Program Memory window displays the contents of the ROM.

• From the View menu, select Program.  The Program Memory
window appears.

Figure 20 – Program Memory Window

You can not modify data in the address field.
Each address represents a different group of
programming lines.
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Each value field (0 – f) represents a different
line of programming. For example, the cell in
row 0x000090 and column 2 contains the
program code for line 0x000092.

You can only modify data in the Value fields.  You can not modify
data in the Address field.  To make a change to the ROM program:

• Double click the cell you want to change.

• Type the new value in that field.

Ø Press [Enter] to save the change.

Ø Press [Esc] to cancel the change.
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2.6.3 CPU Registers Window

The CPU Registers window allows you to view and modify the value
for each register on the processor.

• From the View menu, select Registers.  The Data Memory
window appears.

Figure 21 – CPU Registers Window

You can not modify data in the register field.

You can only modify data in the value field.
For information pertaining to the definition of
and the possible values for each register, refer
to the Cypress USB Development Kit
Assembler Guide.
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You can only modify data in the Value field.  You can not modify data
in the Register field.  To make a change to a CPU register:

• Double click the value you want to change.

• Type the new value in that field.

Ø  Press [Enter] to save the change.

Ø Press [Esc] to cancel the change.

Note
For information pertaining to the definition
of and the possible values for each register,
refer to the specific microcontroller’s data
sheet.
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2.6.4 IO Registers Window

The IO Registers window allows you to view and modify the value for
each IO port.

• From the View menu, select IO Registers.  The IO Registers
window appears.

Figure 22 – IO Registers Window

You can not modify data in the Port field.

You can not modify data in the address field.
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You can only modify data in the value field.
For information pertaining to the definition of
and the possible values for each register, refer
to the Cypress USB Development Kit
Assembler Guide.

You can not modify data in the Type field.
Possible entries for this field are R (read
only), W (write only), and R/W (read/write).
Write only values do not reflect the last value
written.  Certain IO ports are changed when
read.  These IO ports are marked with an
asterisk (*).  The value does not reflect the
next or previous value read from the port.
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2.6.5 Memory FIFO Window

The Memory FIFO window displays the contents of the FIFO.

• From the View menu, select FIFO.  The IO Registers window
appears.

Note
Not all supported devices have FIFOs.

Figure 23 – Memory FIFO Window

You can not modify data in the Address field.

You can only modify data in the value fields
(0 – f). Once a value is modified, you must
refresh the FIFO to affect the changes to the
FIFO.
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2.6.6 Breakpoints Window

Breakpoints stop your program at strategic points so you can then look
at the current state of your target.  Most debugging activities either
directly or indirectly use breakpoints.

The Breakpoints window contains only the address field.  This field
shows the address of each existing breakpoint to be planted in memory
and triggered when executed.

• From the View menu, select Breakpoints.  The Breakpoints
window appears.

Figure 24 – Breakpoints Window

There are two ways to modify the data in the address field.  You can
set or clear the breakpoint in the program’s .LST file (see “.LST File
Window”) or you can set or clear the breakpoint in the Breakpoints
window:

• Double click the address you want to change or click in an
empty cell.

• Delete the address to clear the breakpoint or type the address of
the new breakpoint.

Ø When you add, change, or delete an address in the
Breakpoints window, the modification is reflected in the
program's .LST file.
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Once an address is modified, you must either run or refresh the
program to plant the breakpoint in memory and be able to trigger the
breakpoint.

2.6.7 .LST File Window

Breakpoints stop your program at strategic points so you can then look
at the current state of your target.  Most debugging activities either
directly or indirectly use breakpoints.  There are two ways to set or
clear a breakpoint.  You can add, change, or delete the address of the
breakpoint in the Breakpoints window (see section 2.6.6, “Breakpoints
Window") or you can perform the following:

• From the Open dialog box, open the .LST file of the program
you want to work with.

Figure 25 – .LST File Window
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• To set a breakpoint, double-click on the margin to the left of
the instruction where you want the program to stop.  Breakable
addresses appear in blue.

• To clear a breakpoint, double click on the instruction where
you set the breakpoint you want to clear.

Ø When you set or clear a breakpoint, the change is also
reflected in the Breakpoints window.
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Appendix A Acronyms and Abbreviations

The following is an alphabetical list of acronyms and abbreviations
found in this document and their definitions.

Term Definition

CD Compact Disc

CD-ROM Compact Disc Read-Only Memory

COM Communications

CPU Central Processing Unit.

FIFO First In First Out

HEX Hexidecimal

I/O Input/Output

ITTS Intelligent Tracing Trigger System

K Kilo- (one thousand)

M Mega- (one million)

PC Personal Computer

PDF Portable Document Format

RAM Random Access Memory

ROM Read Only Memory

USB Universal Serial Bus

VGA Video Graphics Adapter

www World Wide Web
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Appendix B Detailed Hardware Description

Platform Board

The following diagram is an approximation of the components on the CY3654
Platform Board.  Each component is described in the table on the following page.
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Item Board # Description

J1 Serial Port

J8 USB Connector (not used)

J9 Power Connector

J10/J11 Personality Board Connectors

Jumpers

J12/J13 ITTS Option Board Connectors (future option)

S1 Emulator Reset

S2 Flash Mode

S3 M8 Reset

Switches

S4 Not used

D1 Power – on when power is supplied

D2 Busy – on when executing host command or board init.

D3 Run – on when user program is running

D4 Suspend – on when M8 processor is in suspend mode

D5 Halt – on when user program is halted

LEDs

D6 Active – blinks when board is active

Misc. F1 1 Amp Fuse


