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In the box 

The following components are included in the DK-S7G2: 

• DK-S7G2 Main Board (DK-S7G2M V3.0) 

• DK-S7G2 Breakout Board (DK-S7G2B V3.1) 

• Detachable 4.3-in. resistive-touch WQVGA TFT LCD panel (DK-S7G2LCD V3.0) 

• Detachable CMOS VGA camera module 

• One USB Type A to Micro-B cable 

• One Ethernet cable 

• Multi-region 5V power supply 

• Quick Start Guide 
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Overview 

This Kit and the associated development tools provide the user with a platform to develop products with the Renesas 

Synergy™ S7 microcontrollers. This Quick Start Guide will walk the user through using the Out-of-Box Demo then give 

step by step directions to develop, configure, generate, build, download and execute the “Blinky” SSP project. 

   

DK-S7G2 Kit 

NOTE: This Quick Start Guide covers version 3.0 of the DK-S7G2 Development Kit. 

Prerequisites 

Required software and tools 
• Minimum PC Requirements: Microsoft® Windows® 7 with Intel® Core™ family processor running at 2.0 GHz or 

higher (or equivalent processor), 8 GB memory, 250 GB hard disk or SSD, USB 2.0, Connection to the Internet  

• e2 studio Integrated Solution Development Environment (ISDE) from Renesas 

• Renesas SynergyTM Software Package (SSP) 

Installation 

Tools are available for download at: https://synergygallery.renesas.com 

 

NOTE: 

Version numbers of the tools may change. Below we show the versions that were available when 

this document was developed. 

 

1) Download and install the latest revision of the Development Tool - e2 studio (ISDE) following the below instructions: 

(NOTE: Unless informed otherwise below, use the default options.) 

a) You must select at least the Renesas Synergy™ Family when the below dialog box appears. 

 

b) You must select the additional software “GCC ARM Embedded 4.8.2014q3” when the following dialog 

box appears. 
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2) Download and install the latest revision of the Synergy Software Package using the default options.  

Connecting the board components 

1) Set the JTAG DIP switch 6 on S5 to ON (toward the LEDs). 

 
 

2) Verify all of the S101 DIP switches on the Breakout Board are set to OFF. 

 

3) Using the power supply provided with the DK-S7G2 kit, apply power through the 5V barrel connector (J1) on 

the Main Board. LED3 will turn on Green with a flashing-Red below it. The solid-Green/flashing-Red LED3 

informs the user that the kit cannot communicate with the PC on the debug port. 
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4) Connect the USB cable provided with the DK-S7G2 J-Link OB (J17) on the Main Board. 

 

 

 

 

 

 

 

 

 

 

 

5) Connect the other end of the USB cable to a USB port of the PC. Now LED3 will turn solid-Green, indicating a good 

connection. 

 

Out-of-Box Demo 

1) During initialization, the S7G2 will turn Red and Green the LEDs that it can control and it will turn on and off the Red 

LEDs inside the Ethernet connectors so you can verify those work. At the end of initialization, LED1 and LED2 are off 

while the Configuration LEDs, LED6 to LED12 will be green. 

2) A splash screen will be displayed on the LCD showing a date and time.  
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3) Press anywhere on the splash screen to go into the Thermostat Demo. 

 

 

 

4) Press <Settings> on the top right. 

 

 

5) Go into Units, Display, Set Time, Set Date and Sound to make adjustments to the demo.  

 

6) Click on the left side of the Thermostat main screen to enter the Thermostat control menu. 
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7) Within the Control Menu, adjust the System, Fan, and Temperature.  Press the Help button to show the detailed Help 

screen. 

 

 

Running Blinky 

The Blinky Project is included in the SSP.  To run the Blinky Project, you must first create a Renesas Synergy Project in 

the e2 studio ISDE; you can then debug and run the project on the DK-S7G2. 

 

Creating the Blinky Project 

To create a project: 
 

1) Start the e2 studio ISDE. Click <e2 Studio>  under Windows Start Menu -> Renesas Electronics e2studio -> e2 studio 

NOTES: 

a) The e2 studio ISDE confirms the installed tool chain(s) the first time it is started after installing the toolchains.  

b) If the e2 studio ISDE displays the Welcome to e2 studio screen, review and click the [X] (it will not be 

displayed again). 

c) If you do not have a compatible tool chain installed, see section Prerequisites. 

2) If the Workspace Launcher Dialog box is displayed, click <OK>.  

NOTE: Until you select “Use this as the default (workspace) and do not ask again”, the Workspace Launch window 

will be displayed when e2 studio is started. 
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3) Start a new Synergy Project by clicking on File > New > Synergy Project. 

The ISDE displays the Project Configuration (Synergy Project) dialog box. 

 

 
 

4) Enter “Blinky_DK_S7G2” as the Project name. 

 

5) The first time you configure a project you need to load a license file. Click on the browse icon of the License 

File and if needed browse to C:\Renesas\e2_studio\internal\projectgen\arm\Licenses\ (if you installed to the 

default locations).  

NOTE: After you have loaded the license file it will be loaded and displayed in License window by default.  

 

6) Click Next. 

The ISDE displays the Project Configuration (Synergy Project) window with the Device Selection options. 

 

7) Select S7G2 DK and leave all other options in this window at their default settings.  
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8) Click <Next>. 

The ISDE displays the Project Configuration (Synergy Project) window with the Project Template Selection 

options. 

  
 

9) Select S7G2-DK Blinky 

 

10) Click <Finish>. 

 

NOTE: 

The e2 studio ISDE has built in Perspectives. Until you inform the tool to remember your selection, it 

will ask if it can use the Synergy Configuration Perspective as shown below.  

  

 

11) If the Open Associated Perspective dialog box appears click <Yes>.   

 

12) The ISDE automatically configures the SSP to load and generate the necessary configuration files for the 

microcontroller hardware associated with the selected board. 

The ISDE displays the Synergy Project Editor where you can see all generated files and configurations by 

selecting the Clocks, Pins, Threads, ICU, and Components tabs. 

IMPORTANT NOTE: 

Don’t be afraid to look around and check things out. The most important thing to remember is Edit->Undo will 

fix most anything you do that you want to take back!  
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13) Generate the project content by clicking on the < > button. 

14) Build the project by selecting Project -> Build Project or clicking on the Build icon . The Blinky Project 

should build with no errors. 

 
 

Debugging and running the Blinky Project 

To debug and run the project, follow these steps: 

1) Configure the debugger by selecting the drop-down menu next to the debug icon and select  

<Debug Configurations…> 
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2) Select your Blinky Project <Blinky_DK_S7G2 Debug> 

 

  

3) Click Debug. 

 

NOTE: 

If asked to Confirm Perspective Switch, click <Yes>.  (If you click the <Remember my decision> check box 

before clicking <Yes> you will not see this selection again.) 

 

 

 

NOTE: 

If the update J-Link firmware dialog box is displayed, we highly recommend that you click <Yes>. 
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The ISDE downloads the project onto the board.  

 

4) Click on the Resume icon, ,  and the software will run till hal_entry ().  

 

5) Click on the Resume icon, ,  and the software will run turning LED1 on and off at a pretty fast pace  

Next steps 

You can review the code for the Blinky project in the src directory of your project. 

 

 
 

 

Application Notes and Demonstration Applications are available in the Synergy Software Package page → “Demos and 

Applications” tab of the Renesas Synergy Gallery https://synergygallery.renesas.com/ssp. Examples of the categories we are 

developing are: 

 Wired Connectivity (CAN, RS232/485, TCP/IP, Web Server, networking services) 

 Bluetooth Connectivity (Bluetooth Classic and Bluetooth Low Energy connection to mobile devices using 

various profiles ) 

 WiFi Connectivity (Access Point Enumeration, Access Point connection using secure protocols, TCP/IP, Web 

Server, networking services) 

 Multi-media (webcam, audio playback & record, audio processing, GUIX tutorials) 

 MCU Performance & Power Measurement (thread, throughput, and I/O performance, low-power modes & 

power measurement) 

 Security (protected memory and bus access examples, stack security examples, security protocols and services 

examples) 
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Reload the Out-of-Box Demo 
Should you desire to reload the original Out-Of-Box demonstration application, you can find it and the instructions to reload 

it, in the Synergy Software Package page → “Demos and Applications” tab of the Renesas Synergy Gallery 

https://synergygallery.renesas.com/ssp. NOTE. The Out-of-Box demo on the Synergy Gallery may be an updated and 

improved demo. This kit contains version 1.0 of the DK-S7G2 Out-of-Box Demo. 

 

Orderable Part Number 
Part Number for this DK-S7G2 Development Kit is YSDKS7G2S30WS2 

 

Support 
Support:  https://synergygallery.renesas.com/support           

 
Technical Contact Details 

               America:  https://renesas.zendesk.com/anonymous_requests/new 
               Europe:  http://www.renesas.eu/support/index.jsp 

    Japan:     https://synergybeta.renesas.com/ 
 

 



 

 

 

Notice
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples.  You are fully responsible for

the incorporation of these circuits, software, and information in the design of your equipment.  Renesas Electronics assumes no responsibility for any losses incurred by you or third parties arising from the

use of these circuits, software, or information.

2. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics does not warrant that such information is error free.  Renesas Electronics

assumes no liability whatsoever for any damages incurred by you resulting from errors in or omissions from the information included herein.

3. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights of third parties by or arising from the use of Renesas Electronics products or

technical information described in this document.  No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or

others.

4. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.  Renesas Electronics assumes no responsibility for any losses incurred by you or

third parties arising from such alteration, modification, copy or otherwise misappropriation of Renesas Electronics product.

5. Renesas Electronics products are classified according to the following two quality grades: "Standard" and "High Quality".  The recommended applications for each Renesas Electronics product depends on

the product's quality grade, as indicated below.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic

equipment; and industrial robots etc.

"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-crime systems; and safety equipment etc.

Renesas Electronics products are neither intended nor authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems, surgical

implantations etc.), or may cause serious property damages (nuclear reactor control systems, military equipment etc.).  You must check the quality grade of each Renesas Electronics product before using it

in a particular application.  You may not use any Renesas Electronics product for any application for which it is not intended.  Renesas Electronics shall not be in any way liable for any damages or losses

incurred by you or third parties arising from the use of any Renesas Electronics product for which the product is not intended by Renesas Electronics.

6. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, especially with respect to the maximum rating, operating supply voltage

range, movement power voltage range, heat radiation characteristics, installation and other product characteristics.  Renesas Electronics shall have no liability for malfunctions or damages arising out of the

use of Renesas Electronics products beyond such specified ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have specific characteristics such as the occurrence of failure at a certain rate and

malfunctions under certain use conditions.  Further, Renesas Electronics products are not subject to radiation resistance design.  Please be sure to implement safety measures to guard them against the

possibility of physical injury, and injury or damage caused by fire in the event of the failure of a Renesas Electronics product, such as safety design for hardware and software including but not limited to

redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures.  Because the evaluation of microcomputer software alone is very difficult,

please evaluate the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product.  Please use Renesas Electronics

products in compliance with all applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive.  Renesas Electronics assumes

no liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

9. Renesas Electronics products and technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or

regulations.  You should not use Renesas Electronics products or technology described in this document for any purpose relating to military applications or use by the military, including but not limited to the

development of weapons of mass destruction.  When exporting the Renesas Electronics products or technology described in this document, you should comply with the applicable export control laws and

regulations and follow the procedures required by such laws and regulations.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, who distributes, disposes of, or otherwise places the product with a third party, to notify such third party in advance of the

contents and conditions set forth in this document, Renesas Electronics assumes no responsibility for any losses incurred by you or third parties as a result of unauthorized use of Renesas Electronics

products.

11. This document may not be reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) "Renesas Electronics" as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2) "Renesas Electronics product(s)" means any product developed or manufactured by or for Renesas Electronics.

http://www.renesas.com
Refer to "http://www.renesas.com/" for the latest and detailed information.
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